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Department of Special Education
Ball State University

Developing Your Digital Portfolio Website

The following steps will guide you through the process of developing your personal
digital portfolio if you are using a Macintosh in TC 709. Slight variations may be
necessary if you are using Macintosh computers elsewhere or using Windows
computers.

Step 1: Beginning
Introductory sessions for beginning your digital portfolio will be held in TC 709.

Step 2: Download the Digital Portfolio Template
This step downloads the Special Education digital portfolio template documents to your
computer desktop.

• Open a web browser—Netscape or Explorer.
• Go to http://www.bsu.edu/spced
• Along the left side, click on the link Student Information
• Browse the information available to you about our department. Locate—under

Digital Portfolio Template—the link: download the portfolio.sit
• Clicking on that link will automatically download the portfolio.sit document to

the desktop of the computer where you are working—either directly onto the
desktop or into a Download folder on the desktop.

• A window may appear asking what Netscape should do with this file. If so,
make sure that Open Using Stuffit Expander is selected, then click OK.

• Quit (from the File or application menu) the browser software.
• The computer has a program that automatically expands the compressed (.sit)

portfolio.
• Locate both portfolio.sit and the portfolio folder in the Download folder or

on the computer’s desktop.

portfolio.sit is a compressed image of the portfolio folder and all of its contents.
Its only purpose is to compress the documents into a single image for web
distribution. You will be working with the documents in the expanded
portfolio folder.

Step 3: Save the Portfolio Documents
If you have your own iBook, you will probably be saving documents on that computer.
Students working on a lab computer will work on the document on the computer
desktop and then will move the entire folder to their iWeb space for storage. There is no
need for any sort of data disk—zip disk or thumb drive.
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Views

Step 4: Explore the Portfolio Documents
This step introduces you to the documents in your portfolio folder.

• Open (double click) the portfolio folder from your Zip
disk and look at all of the documents. If you are viewing
the folder with an icon view, experiment with the view
options, as illustrated, to see the contents of your portfolio folder a different
way.

• Double click on the file named: index.html to open the first page and view
the different parts of the template through a browser.

• Click the blue arrow near the bottom of the index page to move to the next page
of your portfolio.

Notice that you now have a two-part page. There is a frame of navigation buttons on the
left to lead the user to the different parts of your portfolio. There are different pages
that load into the frame on the right as you access different buttons from the navigation
frame.

• Click on the various buttons; notice that the navigation frame does not change
as the individual information pages load into the right side of the screen. Try all
of the buttons on the navigation frame on the left. You can return to the home
page by clicking on the Home button in the navigation frame. The pages that
load into the right side of the screen are the ones that you will be personalizing.
The navigation frame will remain as it is now. It needs no editing.

• Quit the browser software—Choose Quit from the Netscape menu or the File
menu.

• Look again at the list of documents in the portfolio folder. All of the documents
have extenders at the ends of their names—3 or 4 letter abbreviations. The
images have either jpg or gif after their names. These are graphic formats that
are “web-friendly.” All of the other documents have html extenders. These files
are the instructions that make each page appear as it does.

As you begin to personalize your web page, you will be editing these html pages,
changing text, adding links, adding images, etc. It is very important that all content you
intend to use in your web site be placed in the same portfolio folder.

RULE #1: Place all new or edited documents into your portfolio folder
before you establish any links or publish any documents.

Step 5: Explore the Netscape Composer Environment
This step helps you begin the process of personalizing your portfolio.

• Double click on the portfolio folder to open it. Save often, especially if you are
working on a longer document.
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• Double click on the file index.html to access the first page of your personal
portfolio. The web browser window should now show the portfolio template
page titled Professional Portfolio. (You should be in Netscape
Communicator, not Internet Explorer).

Note: If your index file opened in Internet Explorer instead of in Netscape, first, choose
Quit from the File (Explorer) menu to stop Explorer. Then use the tip below to assure
that your document will open with Netscape.

Tip: When using a Macintosh computer running OS X, there is a shortcut for opening a
document in a preferred application. Do this: Locate the application’s icon on the Dock.
Drag the document’s icon to the application icon on the Dock. When the application’s
name pops up, drop the document; it will automatically open.

You are looking at your index.html document in a browse mode. That is, all buttons and
links work, and editing of the page is not possible. In order to make changes in the
document you must be in the edit mode. Do this:

• Open the File menu and select Edit Page…. A new window will open up which
looks almost exactly like the page viewed in the browse mode except
Composer is included in the page heading. An extra hint that you are in
Composer is that you will see tool bars and/or formatting options at the top of
the window.

A. Examine the Composer Tools

The Composer’s environment offers basic tools directly in your view—on the toolbars. If
you do not see these toolbars at the top of the Composer window, click on the tiny
triangles along the top left edge of the window.

Now, move your cursor over each icon to discover its purpose.

B. Edit the Index Page

• Select the words Your Name by dragging across them. Type in your own
name. Experiment with the toolbar buttons to modify the text color, size, or
style. Then Save this edited page—from the File menu choose SAVE. It
updates the original index.html file in your portfolio folder.
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C. View Your Edited Page

• Click on the Browse tool on the toolbar to view your saved document in the
browse mode.

• If you do not see your name on the page, click on the Reload Page button to
view your saved changes.

• You now have two windows open for the same document—one for the browser
and one for the composer. If you click on the yellow button at the top left of
either window you will be minimizing that particular window. Minimizing
shrinks the window, placing a tiny image of it near the right end of the Dock.
You can easily switch between these windows by clicking the yellow button to
“hide” a window and clicking the Dock image to display it again. Try this now!

• Each time you edit, save, and browse, use the minimize button to “park” unused
windows on the Dock

Rule #2: Edited web pages must be saved and reloaded in the browser in
order to view the changes.

D. Edit home.html
Now, you will continue editing by examining the page home.html.

• To continue, you should be on the index.html page in the Browse mode.
• Scroll down the index.html page and click the arrow to move to the second page

of the template. This page is headed Your Name and includes a link to your e-
mail and a Smiley Face picture. You will also see some guidelines you will use to
write your own introduction later.

Do you remember when you previously browsed the portfolio and noticed that the right
side of the page changed but the navigation frame on the left did not? Pages that have
frames have a special property called a frameset. The frameset cannot be edited in the
same way as you edited the index page. Even though you are loading pages into the right
side of the frameset, the actual page that is open is the frameset page. So, when you are
on a page with frames, like your page with buttons along the left edge, you cannot use
Edit page like you did with the index page.

Different browsers, different versions of browsers, and other web authoring software
offer various options for editing web pages that contain frames. Since you will only be
editing pages that are html pages and not frame pages, you should be opening each html
page that you wish to edit directly from your portfolio folder. In OS X there are two ways
you can do this:
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Drag to left

1. Choose Open File from the File menu
and navigate to the portfolio folder on
your disk. You may need to drag the blue
scroll bar all the way to the left to locate
your Zip disk on the desktop—see
illustration. Open home.html.

or

2. Drag the home.html document from your
portfolio folder onto the Netscape icon on
the Dock.

When the file opens notice that it opens in its own browser window without being
part of the frame page. There is no navigation frame. Now, choose Edit Page…
from the File menu to enter the Composer mode to customize this page. The red,
dotted lines define a table format, which helps organize the page. The red lines do
not appear when you browse the page—only when editing.

E. Edit home.html

• Highlight Your Name and replace it by typing in your name.
• Highlight the email address and replace it by typing in your e-mail address.

Use the following steps to activate your e-mail address:

• Highlight your e-mail address, and then click on the Link tool (the chain links)
in the tool bar at the top of the window or choose Link... from the Insert menu.

• In the small window under Link Location, type: mailto:your e-mail address
(no spaces)

• Click OK

• At this time, do not write the introduction of yourself. Later, you may want to
write this introduction using your favorite word processing program, carefully
edit it, and then copy and paste it into the web site—when prompted by your
instructor. See instructions later for replacing the Smiley Face image with an
image that you choose.

• Save this edited page. It will update the home.html file in your portfolio folder.
• Now, Browse the page to observe your changes. Note: Your e-mail link may not

work on the lab computers because outgoing mail is not enabled in these
browsers.

• Print this Smiley Face page so you have printed guidelines to write your
introduction later.
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Rule #3: Always keep the latest version of each of your portfolio documents
in your portfolio folder for easy access to editing.

Step 6: What’s Next?

You are free to modify your portfolio documents, personalizing them as you choose.
However, the viewer should be able to easily access the following basic elements:

• A title page with your name, a picture, and an introduction to yourself.
• A page for your philosophy of education.
• Ten INTASC standards pages where you will place a) a dated reflection for each

decision point, b) written rationales for each artifact, and c) links to all artifacts.
• Obvious navigation links so that the viewer can freely and easily move through

your documents.

What other tools does Netscape Composer offer beyond the basics you have already
seen? While in the Composer mode browse the menus for other features. For example,
Page Color and Background enables you to “tile” an image or color the background of
your pages. Learn about other features through the Help menu.

Step 7: Publishing Your Portfolio to the Web
Publishing places your portfolio to the web so others can view it. Publishing is, in effect,
the process of “turning it in.” Your instructor will evaluate the completed assignment by
accessing it on the web. Since many of you are saving to your iWeb space, you will
submit the address (URL) of your digital portfolio when it is time to turn it in. Those
working on their own computers should be prepared to publish to their iWeb account.
Until then, continue working on your portfolio documents, until you are instructed to
submit your URL.

The group instruction ends here. The remaining instructions provide information for
you as you work on your portfolio documents at a later time.

To view your published portfolio use the following address:
http://username.iweb.bsu.edu/portfolio.index.html

Step 8: Your Digital Portfolio Revisited
The following sections will guide you in returning to add portfolio materials in the
future.

A. Editing INTASC Standards Pages—Writing Reflections

Locate the specific html document—numbered by standard—from the portfolio
folder on your Zip disk. Open it in Netscape, choose Edit page… from the File
menu, write and date your reflection, and then Save the changes.
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B. Editing INTASC Standards Pages—Adding Artifacts

In your initial experiences with editing your portfolio, you edited pages that were
already in the portfolio folder—adding your introduction, your reflections on the
INTASC standards, and maybe your philosophy of education. You will be returning to
your portfolio to add text documents, scanned documents, digital images, PowerPoint
presentations, or perhaps even sound files or digital video as artifacts that demonstrate
your proficiency with each of the INTASC standards. It is beyond the scope of this
document to teach you how to scan documents or photographs or how to take digital
images. However, when you have prepared artifacts to include in your portfolio, use the
following guidelines:

• Photographs or graphic images should be in a gif or jpg format for web
viewing—use jpg for photographs and gif for all other images.

• Text documents (previously typed) should be saved as pdf, html or web page,
or, preferably, can be copied and pasted directly into the appropriate standards
page—much like you typed the text for your introduction or your reflections.

• Previously prepared documents can also be scanned, saved in a gif format, and
included as part of your portfolio.

• All new portfolio documents should be named with all lower case letters with no
spaces included in their filenames.

• Place new files into your portfolio folder  and publish, as before.

C. Creating a PDF Document from any Artifact

The pdf format is “portable document format,” a cross-platform document format that
displays your documents exactly as you have created them, regardless of the software
used to create them. Adobe Acrobat Reader (Mac or PC—free to download from the
Internet) can open any pdf document.

The Mac OS X system has a built-in
option to turn any document into the
pdf format. To do this, first have the
document open. Then initiate
printing. When the Print dialog box
appears notice the Save As PDF...
box at the bottom as illustrated.

Click this button to open a save box
where you can name the document
and select the location to save. Be sure to use the “.pdf” extender on the pdf document
name or users of other computers or systems may not be able to view it. Place the pdf
document in your portfolio folder. Create a link on the appropriate page, save, and
publish.
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D. Editing INTASC Standards Pages—Making Links to the Artifacts

In order for you to view your new artifacts in the browser they need to be linked to the
particular page from which you wish them to be accessed. For example, let’s say that you
have a document, named lessonplan2.html that you have placed in the portfolio folder
on your computer. Perhaps it is an artifact for INTASC Standard 8. You will have to
place a link on the Standard 8 html page in order for the viewer to be able to click on a
link to see the lesson plan document. Review Rule#1!

1. Making a link to an html/pdf document on your disk

• First, open the INTASC html document in which you would like to place a link,
from your portfolio folder.

• Choose Edit page from the File menu.
• You can designate specific text that you wish the user to click on to see your

artifact. For example, “You can examine a lesson plan on pond life that I
prepared for a science class.” The reader will notice that if they click on the
words lesson plan they will be directed to the lesson plan document.

• Add the text that you would like to use to link to your new artifact. Typically, the
text will be a part of the rationale you write to justify the artifact’s placement on
that particular INTASC page. Highlight only those exact words that you would
like to serve as a link. (There is already text placed on the INTASC pages for
linking to an artifact. You may use this text or replace it with your own.)

• Choose the Link Tool from the tool bar or choose Link… from the Insert menu.
• The Link Location will be the actual file name you have given the document in

your portfolio folder. TYPE IT CAREFULLY! Alternately, you could click on
Choose file... and navigate to the document previously placed in tyour
portfolio folder.

• Note: Be careful that the link contains only the document’s actual name and
not any additional text—no path name to that document.

• Save the edited html document.

Rule #4: Publish the artifact document AND the edited html
document—when you are ready to publish.

Remember Rule #1, Rule #2, and Rule #3!

2. Making a link to a gif or jpg in your portfolio folder
The instructions in this section assume that you have previously prepared the images
and placed them in your portfolio folder. Carefully note the EXACT filename of each
image that you will be adding to your portfolio. Read each of the different methods,
described below, to decide how you want to use the image in your portfolio.

• To replace an image that has already been placed on a page—like the
Smiley Face—open the html page that displays the image, and choose Edit
page… from the File menu. Double click on the image to “open” the Image
Properties dialog box. Notice the URL for the present image. Simply type the
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filename of the image you wish to appear in its place and it magically appears
on the page! Save the edited html page—and remember Rule #4.

• To place a new image on an html page of text, click into the text at the
place you wish the image to appear. You may want to press [RETURN] to
provide a little space within the text. (The image will actually be spaced within
the text as a giant text character and it behaves like text.) From the Insert menu
choose Image… and the Image Properties dialog will appear. Carefully type
the image name exactly as you have it saved in the portfolio folder of your disk.
After the image appears on the page you may wish to press [RETURN] again to
adjust spacing. If you want to add a text caption, type it now, and then save the
html page. Don’t forget Rule #4!

• To make an image open in its own page—perhaps it is large—create a text
link like in the lesson plan example described previously, only the filename is
the exact image filename, not an html document. When the user clicks on the
text link, the picture opens in its own page. This works–except that the user
must  close the window to return to the last page viewed.

Note regarding images that you display on your web pages: Place meaningful
text into the alternate text field when making links to images. This provides users, who
are relying on screen readers, text that can briefly describe the image.

3. Making a link to a PowerPoint presentation
You may wish to include a PowerPoint presentation as an artifact for one of your
INTASC standards. First, open the presentation and from the File menu select Save as
HTML…. The software will convert your presentation document into a collection of
individual files, all of which go together to deliver your presentation from the web. The
saved folder and html document that result from the conversion are named based on the
original name you gave the presentation. You will see a folder named:
originalname_files and a single file named: originalname.htm

• It is important that you publish these documents to the proper location in your
web account. Place both the folder of files and the htm document outside of
the portfolio folder—loose in your account! Why? You’ll soon see why!

• Open the html document on your Zip disk from which you want to make a link
to the presentation, enter the edit mode (Composer), and highlight the text that
you wish to become a link to your PowerPoint presentation.

• From the Insert menu, choose Link…. Be careful here as there are some special
steps you must take at this point. The name you type into Link Location must
contain the complete path to the document:

e.g.:  http://www.bsu.edu/web/your username/originalname.htm
(originalname.htm is the name of the html document generated by the
conversion of your PowerPoint document.

• Next, within the same Link Properties dialog box click on Advanced Edit….
• When the Advanced Attributes Editor opens, at the bottom, notice two

small text fields—Attribute: and Value:. The attribute field has a small button
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that, upon pressing, reveals a list of attributes. Select target. Then, into the
value field type:  _blank  (That is, the underline character followed by the
word blank.

• Save and publish this revised html document.
• Now, access your portfolio through the Internet and view the PowerPoint

presentation. This can be tricky because of the frameset that your portfolio
uses. Because PowerPoint also uses frames, the presentation cannot be
displayed within a frame like your other html documents can. If your
presentation does not work, check that you published both the htm document
and also the folder of files to a location loose in your publishing area and not in
your portfolio folder. Also, do not place the htm document inside the folder of
files. The path name that you typed may have an error too. Check it carefully!

Note: You may have noticed that PowerPoint creates an “.htm” document, not
“.html.” This is not a typo! Both extensions are “legal” for html documents, but
are not interchangeable. When creating a link to an “.html” or an “.htm”
document, be sure to use the exact extension on your document to create your
link.

Tips and Troubleshooting

Remember the Rules:

RULE #1: Place all new or edited documents into your portfolio folder
before you establish any links or publish any documents.

Rule #2: Edited web pages must be saved and reloaded in the browser in
order to view the changes.

Rule #3: Always keep the latest version of each of your portfolio documents
in your portfolio folder for easy access to editing.

Rule #4: Publish the artifact document AND the edited html
document—when you are ready to publish.

To get additional help with all aspects of creating web pages in Netscape Composer,
while you are working with Composer, from the Help menu choose Help and Support
Center and then the section Creating Web Pages.

To “right-click” (reveal a contextual menu) on the Mac, press [ctrl]or [CONTROL] as
you press the mouse button.

When experimenting with background colors and images for your pages, take care not to
degrade the readability of text on the page.
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To change an image size, open and edit the html page containing the image. Double click
the image to view the Image Properties dialog. Click on Custom and check
Constrain to preserve the image height and width ratio. If you “mess up,” simply click
on Actual Size to restore the original. These changes only affect how the image is
displayed on the page and do not change the image stored on your disk. Other image
attributes such as spacing and alignment with text are available through this same
dialog box. If you are using many images, explore these options to present your artifacts
in the best way possible.

To create a link to a published web site on the Internet—not within the BSU
network—first use a browser to go to the exact page you want your viewers to have
access to. Copy the URL—including the prefix; e.g., http://www.pagename. Return to
the html page, in Composer, where you wish to place the link. Highlight the text, click
the Link tool on the toolbar or open the Insert menu and choose Link…. Paste the
complete URL into the Link Location. Save the html page and publish it as usual.

When including a previously produced document that has been converted to html, you
should proofread the html copy carefully. For example, a text document written with
Microsoft Word using a bullet format will display the bullets as accented vowels when
converted to html. To fix this, just open the new html document in Navigator, choose
Edit page… and type in any necessary changes.

To use symbols or special characters in text that appears in any html document, enter
the characters while editing the html document. Open the Insert menu and choose
Characters and Symbols.

Use TC 709 portfolio help services when you need additional help. Portfolio help hours
are posted in the lab. Also visit the PT3 Digital Portfolio web site for updates on
workshops and current portfolio issues.

http://www.bsu.edu/web/portfolio


